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Intro

The View tab can be found in all our spatial products and contains various tools
relating to the view and layout of your spatial pane:
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A2 ZoomIn @ Orientation v | [a2] Main View iad Minimap £ Colour Palette o
L= A Dashboards Manage Workspaces ~
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We will start by taking up the View section of the tab.

View

:: Zoom Fit + Pan
J¥ ZoomIn @ Orientation ~
& ZoomOut & Script Buttons

View

Zoom Fit

Zoom Fit will zoom you to the extent of all your layers:
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S ZoomOut # ScriptButtons

View




x 0 selected r_'Jr—J E LER

Layers <« X
Description
..... v & iIoutets

} | W % Sub_Places.shp
3| = % South Africa

i# Layers | Dashboards

Main View =

x QO MMGKN B K|

SRR Retoioutets |
) ~| W% Sub_Places.shp
37| % South Africa

% Layers = Dashboards




Zoom In, Zoom Out, Pan

Zoom In and Zoom Out allow you to zoom in and out of your scene and Pan
allows you to move up, down, left and right in your scene by clicking and drag-
ging in the scene:

4 e y
W Zoom Fit

& Orientation «
& Script Buttons

View

Orientation

By dropping down on Orientation(1) you are presented with a list of different
orientations for your scene that you can choose. These same orientations can be
accessed by clicking on the eye at the bottom of the spatial pane(2) which will
bring up a dialogue:
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As an example, [ will change the orientation of my scene from Top (Default)
view to one of the other orientations:
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Script buttons

Script Buttons is a feature we have that allows you to design your own buttons
and tabs to perform customized operations. This feature is not currently fully
supported but will be soon:

:: Zoom Fit 1-1-' Pan

A ZoomIn @ Orientation ~

2 Zoom Out§ & Script Buttons

View

Layout



= Standard from current ] View 3

[s] Main View

] View 2 [a2] Wiew 4

Layout

In the Layout tab are different views of your scene that you can add. These are
added as separate windows in your spatial pane. As you can see, by the fact that
its greyed, currently I only have the Main View(1) chosen. I will add a second
view of my scene by clicking View 2(2) and as you can see the new view is
added:

7= Standard fromoygrrent ] View 3
(T W 4
[a2] View 2 L=

Layout

i IViewZ I ¥ Layers <«
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(If when your view is added you don’t see the layers displayed on the scene just
zoomfit the new view.)

View3 and View4 will add a third and fourth view.



These views can then be zoomed in and out, have their orientation changed etc.
independent of each other:

! SpatialXL RetailOutlets.xisx N - o X
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X Oselected (8] (¢ -
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What Standard from Current will do is give standard orientations for each
view based on the current orientation in the Main View. The standard orienta-
tions are as follows: View2= Main from left; View3= Main from front;
View4= Main Orthographic:

= Standard from current
] view 3

[&] Main View
[a] View 2

[a] View 4

Layout
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Window
= layers 4 Print Templates
iad Minimap @'} Colour Palette
Dashboards Manage Workspaces
Window
Layers

The Window section of the tab has different windows which you can choose to
have showing and use in your spatial pane. The first of these is Layers which
will display the layer control where you can see and work with your layers (the
layer control is fully described in the Layer Control manual):

i Print Templates

i Minimap % Colour Palette
#Ed Dashboards Manage Workspaces

Window
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Positioning windows

These windows can be positioned in various ways, if you right click on one you
will see you have options to do various things with it:
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Main View
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Close

As another example of how they can be placed, I will first put my Dashboards
window on also and you will see it is added as another tab where my layer con-
trol is, and I can switch between these two tabs:
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But I want to place the Dashboard window underneath my layer control so what
I can do is click on the window and drag it until the placement plan comes up
and then drop it on the bottom box:
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(If after you’ve placed the window like this you don’t then see the window you
might just need to resize the other window so its smaller and then you will see
the window below.)

In fact, you can place these windows anywhere in your spatial pane by using
this method, just click and drag and place at the desired point (hover one of the
boxes of the placement plan so that it turns blue and then you can drop):
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Removing Windows

To remove a window simply exit it or right click and select Close or you can
just go back to the View tab and select the window again and it will turn off and
will be ungreyed.

Minimap
Minimap will show a mini version of your scene that you can navigate by

clicking to pan and mouse wheeling to zoom in or out. This will then navigate
your actual scene:

= Layers ka4 Print Templates

21} Colour Palette

Window
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Dashboards

Dashboards will add the Dashboards window where dashboards can be created
and viewed. For full data on how to use dashboards refer to the Dashboards

manual:

E Layers

i Minimap

A Dashboards Manage Workspaces ~

i Print Templates
1% Colour Palette

Window
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https://primethought.biz/help/spatialvu/dashboards/
https://primethought.biz/help/spatialvu/dashboards/
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Print Templates

Print Templates will add the Print Templates window where you can create
and view print templates. For full data on how to use this feature refer to the

Print Templates manual.:

= Layers -n Print Templates

i Minimap 21 Colour Palette
fEl Dashboards Manage Workspaces

Window
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Colour Palette

Colour palette will bring up the colour palette window (this is a floating win-
dow) where you can add colours to any themes you set for your layers or to the
layers themselves:

E Layers n Print Templates

i Minimap £ Colour Palette

P Dashboards |=:] Manage Workspaces ~

Window
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& Colour Pallette — O et
File  Edit

Bald —h

Unigue .

Blues . .

BluetoRed

PinktoGreen . .

Reds

RedtoGreen . . .

- HNED

E Grld:(hst . .

The way the colour palette works is as follows: In the tabbed sections on the
right are pre-set colour palettes you can use and change as well(1). For example,
if I am applying a theme to a layer, I can drag one of these colour palettes in to
apply it by clicking on the tab name and then dragging(2)(3)(4):
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£ Colour Pallette | X
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Blues
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General Themes | Colours | Thickness/Size HeatMap Images ImageSizes Charts  Scene Tips

Data

Styling Calour Column: | PROVINCE - X

Text

] Colour based on text values | Colour based on number ranges

Thematics

Linke Choose UnigqueColours Clear Sort Ascending Sort Descending

Prajection Value Colour

Input Transform b | EASTERN CAPE 255, 0, 77

Evemik St KMWAZULL NATAL 245, 134, 255
GALITEMG 106, 172, 255

Editing
MPUMALANGA, [ 203, 161, 255
FREE STATE I 0, 209, 179
LIMPOPO = 227, 177, 41
MORTH WEST [ 255, 104, 155
WESTERN CAPE [ 234, 153, 207

Colour Palette

Apply Cancel

Layer Properties - RetailOutlets

General Themes | Colours | ThicknessfSize HeatMap  Images  ImageSizes  Charts | Scene Tips

Data

Styling Colour Calumn: | PROVINCE N ><

Text

) Colour based on text values | Colour based on number ranges

Thematics

Links Choose UnigueColours Clear Sort Ascending Sort Descending

Projection Value E Colour

e e b | EASTERN CAPE B G7, 52, 148

e KWAZULL NATAL G 31, 156
GALITEMG I 45, 130, 139

Editing
MPUMALAMNGA [ 107, 174, 214
FREE STATE [ 189, 215, 231
LIMPOPO [ 237, 248, 251
MORTH WEST Il 7, 52, 148
WESTERN CAPE 3, 31, 156
MORTHERN CAFE I 43, 130, 139

Colour Palette

beply Cancel
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This works the same for applying the colours to a theme legend in the layer con-
trol. You just click and drag onto it as above:
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You can drag individual colours or entire palettes onto layers to change their
colour; however palettes can only be dragged onto layers with more than one
colour (colour theme). I will drag a colour to change my Retail Outlets layer:
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X 0 selected %

Main View N

EEEEEREX®r I

Layers a4 P = X

A Deccript]on

On the left is a gradient of colours(1), the box above the eye shows whatever
colour you are currently on in the gradient(2):
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BluetoRed
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Reds

RedtoGreen

Warm

Datamine

. Grldﬂ_lst

LR E
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You can click on any point in the gradient on the hue you like and then drag that
colour onto a theme element or layer:

&4 Colour Pallette — O >

Bold

Unigque . . .
- ANEE
BluetoRed
PinktoGreen . .
Reds

RedtoGreen . . .
- DEEE
Datamine

.

File  Edit
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Description
~{v| @ & SimpleRetails
~[v| ® % RetailOutlets

Sub_Places.shp
Province

~{v|[l]  Western Cape
~[v|[]  Eastern Cape

~{v|[]  Freestate

[« | kwaZulu-Natal

F
o
[<]
-

== Morthern Cape

T T
-+ v Gauteng

|7 Mpumalanga

=il oo

¥|v|= % South Africa
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Layers 4 B Iz X
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Once you’ve used a colour from the gradient, that colour that you selected re-
mains in the box above the eye and if you want to reapply that colour you can
then click on the box and drag:

£ Colour Pallette — O -

File  Edit

Bold

Unigque

Blues

BluetoRed

PFinktoGreen

Reds

RedtoGreen

Warm
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Description

|| @ % SimpleRetails
- w 4 RetailOutets
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Description
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(Note: If you hover over the gradient before doing this the colour in the box will
change again according to what colour you are over so if you are going to reap-
ply colours just go straight to the box.)
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The brightness of the colours in the gradient can be adjusted using the slider be-
low:

£ Colour Pallette — O -

File  Edit

4

Bold

Unigque

BluetoRed

PFinktoGreen

Reds

RedtoGreen

Datamine

;

hiLil

You can choose to have any colour palette shown as a grid or list by toggling
the Grid/List button. In this example I toggled the Bold palette to be a grid:
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& Colour Pallette — O 5
File  Edit
Bold Colour |R |G |B |Name|
Unique » Il o o 2. Ble |*
Bluss B . & 4 Bo.
2. 1. 80 Coral
BluetoRed ] ore
B @ 0 50 ci
FinktoGreen
Bl o o i Da.
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The little X below will close whatever palette you are currently on (Bold and
Unique are the only palettes you can’t close):

g Colour Pallette — O 3

. . . .
Unigue

Blues

File  Edit

BluetoRed
PinktoGreen

Reds

RedioGresn

—t

0O 20 40 &0 8|0

GridList
X
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Close Palette >
Are you sure you want to close the active Palette?
Yes | | Mo | | Cancel
£ Colour Pallette — O

File  Edit

Bold

Unigue
Blues
BluetoRed
PinktoGreen
Reds

RedtoGreen

Grid/List

To create a new palette go to File>New:
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Edit
= Open Bold
E;J Save Az .
Blues . .
#  Reset Colours BluetoRed
E Close PinktoGreen .

= . .
RedtoGreen

GI.id.II'LiSt . . .
o X

o
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In the dialogue that comes up put the name for the new palette. You can then
choose to copy from an existing palette by having Copy ticked on and then se-

lecting from the dropdown. If you want to create a new blank palette leave this
ticked off. When done click Create:

£ Mew Palette pe

Name: || Route Project |

[] Copy from: Bold Colors w
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Gx Colour Pallette — O W

File  Edit

Bold

Unigque
Blues
BluetoRed
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—
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Your blank palette has been created and now you can drag colours onto it from
the gradient or from the other palettes. Just click on the colour and drag:

G_x Colour Pallette — N 5
File  Edit
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Unigue ol 1]
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BluetoRed
FinktoGreen
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& Colour Pallette — O =
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File  Edit
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You can edit palettes (including the default palettes) using the Edit tab. To re-
move a colour select it and then use Delete Colour. Insert Colour will insert a
blank colour (white). And then you can copy and paste colours using Copy Col-
our and Paste Colour. You can add colours by clicking and dragging them ei-
ther from the gradient or other palettes:

£ Colour Pallette

Insert Colour
Delete Colour Drel

Copy Colour  Ctrl+C

Paste Colour  Ctrl+V

FinktoGreen

Reds
RedtoGresn
Route Project
I .
0 20 40 o0 80 -
- Grid,List
S %
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Once you have created a palette or edited one you can then save it as an external
file that you can then bring in anytime:

£ Colour Pallette — O >
o . . . .
Unigque
Blues
BluetoRed
31 Reset Colours
Close PFinktoGreen
Reds
RedtoGreen
Route Project
Grid/List
X
v £ >
File name: | Route Project] »
Save as type: | Palette files (*.palette) ~
e Folders Cancel

To bring a palette file in you use File>Open. In the File menu you also have the
option to Rename a palette. Reset Colours will set all the palettes back to their
default, which is to say put all the default palettes back as they were before be-

ing changed or having other palettes added. Close will close the current palette:
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Open
% Bold
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Unigque
Mew
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Rename
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Manage Workspaces

Manage Workspaces is fully described in the Manage Workspaces manual:

= layers k4 Print Templates

iad Mirimap &'} Colour Palette

Manage Workspaces

Window
Skins
8 0 % -
G = & -
Skins

The Skins section of the tab gives you a list of skins to choose from for your
spatial pane. You can look through them and choose which one you like best.
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Support

T: +27871354351

support@primethought.biz - primethought.biz
DPrIMEThnugh' Kyalami Estate, Midrand, Johannesburg,
Sofrware Solutions 1684, Souih Afrlca
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